
  

 

Microsoft Dynamics GP: U.S. Payroll 
Year-End Closing Procedures 

 
Introduction 
 
This document outlines the recommended year-end closing procedures for Microsoft Dynamics GP Payroll. 
The year-end close process: 

• Clears out the open year for payroll information and moves all calendar year information to 
history. 

• Creates the year end wage file with annual wage information used to edit and generate W2s, 
W3s, 1099’s, 1095-C’s, 1094-C’s and magnetic media for the year being closed. 
 

This document contains a detailed checklist of the steps that you must follow to complete the year-end 
closing procedures and an alternative checklist to use instead of the standard checklist if you must process 
2024 pay runs before you complete the year-end closing procedures for 2023. The payroll module year-end 
details section contains detailed information about each step. Payroll year-end hints, questions & answers, 
and resources follow the description of the procedures. 
 
What does the Year End Close process do? 

The Year-End process/steps will create the Year End Wage file with annual wage information used to 
generate W2s, W3s, and EFW2's (aka Magnetic Media), 1095-Cs, and 1094-Cs (ACA) for the year 
being closed. 

 
Payroll Regulatory / Year-End Specific information: 

• There are NO changes to W-2, W-3, W-4 forms, or EFW2 magnetic media. 

 
Note: Before you follow the instructions in this document, make sure that you have a complete backup copy 
of the database that you can restore if a problem occurs. 
 
 
Read this whole article before you perform any one of the steps. If you have any questions, contact HOOPS 
at support@hoopsinc.com or call (715) 831-9737. 
 
 
 
 
 
 
 
 
 
 

mailto:support@hoopsinc.com


                                 

 

 

Year-end checklist 
To perform the year-end closing procedures, follow these steps:  

1. Verify that you have installed the latest 2023 payroll tax update. 

2. Complete all pay runs for the current year. 

3. Complete all month-end, period-end, or quarter-end procedures for the current year. 

4. Make a backup of the original file. 

5. Install the 2023 Year-End Update, if it has not already been installed. 

6. Create the Year-End Wage file. 

7. Make a backup of the new file. 

8. Verify W-2 and 1099-R statement information. 

9. Print the W-2 statements and the W-3 Transmittal form. 

10. Print the 1099-R forms, the 1096 Transmittal form and ACA forms. 

11. (Optional:) Create the W-2 Electronic file. 

12. (Optional:) Archive inactive employee Human Resources information. 

13. Set up fiscal periods for 2024, if they have not yet been set up. 

14. (Optional:) Close fiscal periods for the payroll series for 2023. 

15. Install the payroll tax update (2024 Round 1 Tax Update) for 2024. 

Alternative payroll year-end checklist 
If you must process 2024 pay runs before you complete the 2023 year-end closing procedures, follow the 
steps in this alternative checklist: 

1. Verify that you have installed the latest 2023 payroll tax update. 

2. Complete all pay runs for the current year. 

3. (Optional:) Complete all month-end, period-end, or quarter-end procedures for the current year. 

4. Make a backup of the original file. 

5. Install the 2023 Year-End Update. 

6. Create the year-end wage file. 

7. Make a backup of the new file. 

8. Verify W-2 and 1099-R statement information. 

9. (Optional:) Archive inactive employee Human Resources information. 

10. Set up Fiscal Periods for 2024. 

11. (Optional:) Close the fiscal periods for the Payroll series for 2023. 

12. Install the payroll tax update for 2024. 

13. Process the 2024 pay runs. The user date must occur in 2024. 

14. Print the W-2 statements and the W-3 Transmittal form. 

15. Print the 1099-R forms, the 1096 Transmittal form and ACA forms. 

16. (Optional:) Create the W-2 Electronic file. 

 
 
 
 



                                 

 

 

Payroll module year-end details 
 
Step 1: Verify that you have installed the latest 2023 tax update 

Download the latest tax table update and installation instructions for 2023 to ensure your FICA Wage 
Limit is correct. To access the U.S. Payroll Tax Update pages, select the US Taxes link for your version 
within the Microsoft Dynamics GP Resource Directory page or select the following link: 
U.S. Payroll Tax Update for Microsoft Dynamics GP 

 
Note: The latest tax tables will ensure that the FICA wage limit is correct.  To check your tax table 
update date, click on Microsoft Dynamics GP > Tools > Setup > System > and click on Payroll Tax. 
The Last Tax Update should be at least 12/21/2022 (Round 1 for 2023) or later. 

 
Step 2: Complete all pay runs for the current year. 

It is important that you complete all pay runs for 2023 before you install the 2024 payroll tax update. 
If you install the 2024 payroll tax update before completing the pay runs, taxes will be calculated at 
2024 rates for the remainder of the 2023 pay runs. 

 
Step 3: (Optional:) Complete all monthly and quarterly payroll month-end, period-end, or quarter-end 
procedures for the current year. 

For more information about period-end procedures for payroll for Microsoft Dynamics GP, use the 
Printable guides to obtain the printable manual for U.S. Payroll. 
 

Step 4: Make a backup of the original file. 
Create a backup, and then put this backup into safe, permanent storage. By creating a backup, you 
make sure that you have a permanent record of the company's financial position at the end of the 
year. You can restore the backup to quickly recover data if a power fluctuation or other problem 
occurs during the year-end closing procedure. 

 
To create a backup in Microsoft Dynamics GP, follow these steps: 

1. In Microsoft Dynamics GP, select Microsoft Dynamics GP > Maintenance > Backup.  

 Note: The Back Up Company window opens. 

2. In the Company Name list, click your company name. 

3. Change the path of the backup file if it is required, and then click OK. 
 Note: We recommend that you name this backup 2023 Pre Year-End Update to differentiate it from 

 your other backups. 

 
Step 5: Install the 2023 year-end update. 

To install the payroll year-end update, you must follow the steps in the Microsoft Dynamics GP U.S. 
2023 Year-end document. The install must be performed on each computer that has Microsoft 
Dynamics GP installed. Do not log in to your application until the update has been installed on all 
workstations that run Dynamics GP.  
 

https://learn.microsoft.com/en-us/dynamics-gp/resources
https://learn.microsoft.com/en-us/dynamics/s-e/gp/tugp2018_391
https://learn.microsoft.com/en-us/dynamics-gp/payroll/payrollus


                                 

 

 

This update is all inclusive of prior updates and product quality fixes around payroll year end for 
Microsoft Dynamics GP18.4 and GP18.5. EFW2 (Electronic Filing) changes are included in the update. 
 
Note: Be sure to unmark the Launch option after each successful installation. 
 
Note: Please be sure to allow enough time for installing the year end update! HOOPS can assist with 
installing this; please contact us to schedule. 

 When the update is released, install the update and download the 2023 Year End document 
 from U.S. Year-End Update for Microsoft Dynamics GP. 
 
Step 6: Create the year-end file. 

To create the year-end file, follow these steps: 
1. In Microsoft Dynamics GP, select Microsoft Dynamic GP > Tools > Routines > Payroll > Year-End 

Closing. 

2. In the Year field, type 2023, and then click Process. 

Note: You can install the payroll tax update for 2024 any time after the year-end file for 2023 has 
been created. 

 
Step 6a: Print the year-end wage report. 

To create the year-end wage file, follow these steps: 
1. In Microsoft Dynamics GP, select Microsoft Dynamics GP > Tools > Routines > Payroll > Year-End 

Wage Report.  

2. Select the Year, and then click Print. 

Step 7: Make a backup of the new file. 
Create a backup, and then put this backup into safe, permanent storage. By creating a backup, you 
make sure that you have a permanent record of the company's financial position at the end of the 
year. You can restore the backup to quickly recover data if a power fluctuation or other problem 
occurs during the year-end closing procedure. 

 
To create a backup in Microsoft Dynamics GP, follow these steps: 

1. In Microsoft Dynamics GP, select Microsoft Dynamics GP > Maintenance > Backup. 
2. In the Company Name list, select your company name. 
3. Change the path of the backup file if it's required, and then select OK. 

  
Note: We recommend that you name this backup 2023 Post Year-End File to 
 differentiate it from your other backups. 

 
Step 8: Verify W-2 and 1099-R statement information. 

To view the W-2 information in Microsoft Dynamics GP, select Microsoft Dynamics GP > Tools > 
Routines > Payroll > Edit W-2s. 
 

https://learn.microsoft.com/en-us/dynamics/s-e/gp/usgpye2018_396


                                 

 

 

To view the 1099-R information in Microsoft Dynamics GP, select Microsoft Dynamics GP > Tools 
Routines > Payroll > Edit 1099-Rs. 
 
Note: If you change the W-2 or the 1099-R information, we recommend that you make another 
backup. 
 
Note: If you make permanent changes, such as employee address, we recommend changing the 
information on the employee card as well. 
 

Step 9: Print the W-2 Validation Report, W-2 statements and the W-3 Transmittal form 
 To print the W-2 Validation Report, follow these steps: 

1. In Microsoft Dynamics GP, select Microsoft Dynamics GP > Tools > Routines > Payroll >          

Print W-2s. 

2. In the Print W-2 Forms window, specify the following settings: 

a. Print W-2s for: Normal Year-End 

b. Print: Validation Report 

3. Click Print. 

Note: Use report to verify the W-2 information before printing W-2 forms according to the Software Edit 
Criteria specified by the Social Security Administration. You can print the W-2 Validation Report as many 
times as you need to. 
 
To print the W-2 statements, follow these steps: 

1. In Microsoft Dynamics GP, select Microsoft Dynamics GP > Tools > Routines > Payroll >               

Print W-2s. 

2. In the Print W-2 Forms window, specify the following settings: 

a. Print W-2s for: Normal Year-End 

b. Print: W-2 Forms 

c. Select applicable print order 

d. Select applicable Form Type 

e. Select Kind of Employer from drop down, if applicable 

3. Click Print. 

Note: You can print employee W-2 statements as many times as you have to. 
 
To print the W-3 Transmittal Form, follow these steps: 

1. In Microsoft Dynamics GP, select Microsoft Dynamics GP > Tools > Routines > Payroll >           

Print W-2s.  

2. In the Print W-2 Forms window, specify the following settings: 

a. Print W-2s for: Normal Year-End 

b. Print: W-3 Transmittal Form 

3. Click Print. 



                                 

 

 

Note: You can print the W-3 Transmittal Form as many times as you need to. 
 
Note: If you have tipped your employees, print form 8027 for tipped employees.  You must create the 
Year-End Wage file to print this report. Microsoft Dynamics GP > Tools > Routines > Payroll > Form 8027 
 
Hint: If you are in the “Form 8027” window, you can choose ‘Print’ from the File menu, or click on the 
printer icon in the upper right-hand corner of the window to print the Preparation Report for Form 8027. 

 
Step 10: Print the 1099-R Validation Report, 1099-R forms, the 1096 Transmittal form and ACA forms. 

To print the 1099-R Validation Report, follow these steps: 
1. In Microsoft Dynamics GP, select Microsoft Dynamics GP > Tools > Routines > Payroll > Print 

1099-Rs.  

2. In the Print 1099-R Forms window, click Validation Report, and then click Print. 

 Note: Use this option to print a report to verify the 1099-R information. You can print employee 
 1099-R Validation Report as many times as you need to. 
 
To print the 1099 forms, follow these steps: 

1. In Microsoft Dynamics GP, select Microsoft Dynamics GP > Tools > Routines > Payroll > Print 

1099-Rs.  

2. In the Print 1099-R Forms window, click 1099-R Forms, and then click Print. 

 Note: You can print employee 1099-R forms as many times as you need to. 
 
To print the 1096 Transmittal form, follow these steps: 

1. In Microsoft Dynamics GP, select Microsoft Dynamics GP > Tools > Routines > Payroll > Print 

1099-Rs.  

2. In the Print 1099-R Forms window, click 1096 Transmittal Form, and then click Print. 

 Note: You can print the 1096 Transmittal form as many times as you need to.  
 
To print the 1095-C (ACA) forms, follow these steps: 

1. In Microsoft Dynamics GP, select Microsoft Dynamics GP > Tools > Routines > Payroll >                    
     Print W-2s. 

      2. In the Print W-2 Forms window, click 1095-C, and then click Print. 
  
To print the 1094-C Transmittal form, follow these steps: 

1. In Microsoft Dynamics GP, select Microsoft Dynamics GP > Tools > Routines > Payroll >            
     Print W-2s. 

      2. In the Print W-2 Forms window, click 1094-C Transmittal, and then click Print. 
 
 
 
 



                                 

 

 

Step 11: (Optional:) Create a W-2 Electronic File 
To create a W-2 Electronic File, follow these steps: 

1. In Microsoft Dynamics GP, select Microsoft Dynamics GP > Tools > Routines > Payroll > W-2 

Electronic File.  

2. In the W-2 Electronic File window, click to select the check box that is next to each company that 

you want to include in your W-2 Electronic File. 

3. In the User ID Number field, enter the user ID number (formerly called a PIN). 

4. Click Submitter. The Electronic Filer Submitter Information window opens. Enter the submission 

information. 

5. Change the file destination information in the File Name field if it is required. 

6. Click Create File or Save to store the information to create the file later. 

Step 12: (Optional): Archive inactive employee Human Resources information 
To archive inactive employee Human Resources information, select Microsoft Dynamics GP > Tools > 
Utilities > Human Resources > Archive Employee.  

 
Step 13: Set up fiscal periods for 2024. 

To set up fiscal periods for 2024, follow these steps: 
1. In Microsoft Dynamics GP, select Microsoft Dynamics GP > Tools > Setup > Company > Fiscal 

Periods.  

2. In the Year field, type 2024, and then click Calculate. 

 Note: You may want to close all periods except period 1 to prevent users from posting to 

 future periods. This is a ‘soft-close’ and just prevents users from posting transactions to these 

 dates or periods.  

3. Click OK. 

 
Step 14: (Optional:) Close fiscal periods for the payroll series for 2023. 

You can use the Fiscal Periods Setup window to close all fiscal periods that are still open for the year. 
By closing fiscal periods, you prevent users from accidentally posting transactions to the wrong 
period or to the wrong year.  
 
Before you close a fiscal period, verify that you have posted all transactions for the period and for the 
year for all modules. To later post a transaction to a fiscal period that you have closed, you must first 
reopen the period in the Fiscal Periods Setup window. 
 
To close a fiscal period, follow these steps: 

1. In Microsoft Dynamics GP, select Microsoft Dynamics GP > Tools > Setup > Company > Fiscal 

Periods.  

2. Select the Payroll check box for each Period that you close. 

Step 15: Install the payroll tax update for 2024. 
Note: Do not install the payroll tax update for 2024 until the year-end file has been created for 2023 
for ALL companies that process payroll.  The payroll tax update is a system wide update. 



                                 

 

 

To install the payroll tax update for 2024, follow these steps: 
1. In Microsoft Dynamics GP, select Microsoft Dynamics GP > Maintenance > U.S. Payroll Updates 

> Check for Tax Updates.  

2. In the Tax Update Method window, click Automatic, and then click Next. 

3. In the Authorization Number field, type your authorization number, and then click Log in. 

4. Click Finish. 

 
HOOPS PAYROLL YEAR-END HINTS 

 
HOOPS TIP #1:  When printing your W2’s, print alignment forms on blank paper first to see if your fields all 
line up.  Then, when you think they are OK to print, print ONLY one or two of your W2s first, to verify that all 
the boxes are lined up correctly with the form.  Please do these steps before sending all of your W2s to the 
printer!  
 
HOOPS TIP #2:  Tax tables are system-wide, so they only need to be loaded one time.  Service packs and 
year-end update contains GP code, so any workstations that have GP, along with the server’s GP client code, 
must have the same code and service pack versions loaded.   
 
HOOPS TIP #3:  A common error while calculating checks for the New Year while year end is in process: 
“checks cannot be calculated while the year-end closing is in process.”  Resolution:  You need to make sure 
the check date and Dynamics GP user date are both set for the New Year.   
 
HOOPS TIP #4:  There is the option to sort employees by Active employees only – greatly increasing the 
speed in which you can find and sort employees. 
 
HOOPS TIP #5:  Another option for inactive employees is to rename the employee IDs using the Professional 
Service Tools Library (PSTL), which is now a FREE option for all GP customers.   For instance, if your employee 
IDs are alphabetical, you could rename inactive employee IDs to ZZemployee_name so they show up on the 
bottom of the list for lookups. This way you don’t have to delete employee records, and lookup windows are 
cleaner.  Additionally, renaming the IDs to ZZ07employee_name may make it easier to delete an inactive 
range of employees at a later time if you should decide to do so.  
 
 
  
 
 
 
 
 
 

 
 
 



                                 

 

 

PAYROLL YEAR-END QUESTIONS AND ANSWERS 
 
TIMING FOR TAX UPDATE INSTALLATION 
Q: What will happen if I’ve already closed the 2023 Payroll tax year and don’t install the 2024 tax update 
right away? 
 
A: Until you install the 2024 tax update containing FICA, federal and state tax changes, the tax calculations 
for your 2024 pay runs may be incorrect, unless you’ve manually updated your tax tables. 
 
MULTIPLE PAYROLL COMPANIES 
Q: If I use multiple companies with my accounting system, do I have to install the tax update for each 
company? 
 
A: No, the program will automatically update the system tables containing Payroll tax information. All of the 
companies refer to the same payroll tax tables so will reflect the update. 
 
2024 CHECK PRINTING 
Q: I need to print my 2024 checks before I can print W-2’s. What should I do? 
 
A: Once you create the Year-End Wage file, clear financial information, and install the 2024 tax update, you 
can print checks for the new calendar year. Follow the Alternative Payroll Year-End Checklist provided in this 
document. 
 
ALIGNMENT FORM 
Q: When I print the alignment form, information is only printing on the top form. How do I get it to print on 
both the top and bottom forms? 
 
A: To see what W-2’s will look like, you need to print a small range of employees as the alignment form will 
only print the top form. 
 
DIFFERENT EMPLOYER NUMBERS 
Q: If my Employer’s State ID Number and Unemployment ID Numbers differ, do I need to make changes to 
any information to print the employer state ID number on W-2? 
 
A: No. Dynamics GP allows you to maintain state ID numbers separate from unemployment ID numbers, so 
you won’t need to manually change the number back to your Unemployment ID number after creating the 
Year-End Wage File, or enter the Employer State ID number for each applicable employee’s W-2 
information. You can verify that the Employer State ID numbers are correct by referring to the Payroll Tax 
Identification Setup window. 
 Microsoft Dynamics GP > Tools > Setup > Payroll > Tax ID 
 
 
 
 



                                 

 

 

DIRECT DEPOSIT CLOSING 
Q: Is there a year-end closing procedure for Direct Deposit? 
 
A: No, there are no Year-End closing procedures for Direct Deposit.  
 
HUMAN RESOURCES CLOSING 
Q: Is there a year-end closing procedure for Human Resources with Integration to Payroll? 
 
A: There are no year-end closing procedures for Human Resources with Integration to Payroll.  
 
W2 – FOUR TO A PAGE 
Q: Can I print four W-2 statements to a page? 
 
A: Yes, you are able to print four W-2 statements to a page. Four statements for the same employee will 
print per page. The form contains Copy B, Copy C and two Copy 2 forms. Copy A and Copy D must be printed 
separately. Copy A will be printed on magnetic media, if you’re using Federal W-2 Magnetic Media. You can 
still print W-2’s in the 1-Wide Continuous, 2-Wide Continuous and 1-Wide Single Feed forms in all Dynamics 
GP releases supported for the 2023 Year-End and 2023 Payroll Tax Update. 
 
MULTIPLE W-2s 
Q: How do I print multiple W-2 statements for each employee? 
 
A: Using Laser form “sets” – If you want to print all the required forms for each employee at a time (you’re 
using laser form “sets”), simply enter the number of copies you need to print in the “number of copies” field 
in the print dialog box that appears after you select print in the Print W-2 Forms window.  
 
For example, if you need to print four copies of the W-2 statement for each employee, enter “4” in the Print 
dialog box. Information for two employees will be printed per page: Copy A – for two employees, Copy B for 
two employees, Copy C for two employees, Copy D for two employees, etc. until the required number of 
copies have printed for all employees. 
 
Using Laser form “sheets” – If you want to print all forms for all employees, repeat the Printing W-2 
Statements procedure as many times as necessary to print the required number of copies. For example, if 
you need to print copies of the W-2 statements put the Copy A sheets into the printer and follow the 
procedure. Copy A W-2 statement will print for each employee. Then, put the Copy B sheets into the printer 
and repeat the procedure, and so on, until all required forms are printed for all employees. 
 
GREENSHADES 
Q: When does the Greenshades update come out? 
 
A: Greenshades updates are applied automatically when you launch their product. You can rest easy 
knowing you will always have the latest version of the product.  
 
 



                                 

 

 

USER ACCESS 
Q: Should ALL users be out of system for Payroll Year-End Close? 
 
A: No, you do not HAVE to get all users out of GP prior to closing payroll. However, users should not access 
payroll or HR windows during the payroll YE close. Additionally, payroll requires at least two named backups. 
If users are in the system when payroll is closed, and then the pre-close backup should have to be restored 
for any reason, the other users will have to re-key any transactions that they had keyed in the meantime. So 
if possible, the optimal scenario would be for no other users in the system during any module close, 
including payroll. 
 
CLOSING ORDER 
Q: When can you perform Payroll Year-End closing (in what order) 
 
A: Payroll is not dependent upon the other modules. Payroll can be closed first, last, or anywhere in 
between the other modules. The only consideration is installing the year-end code update prior to creating 
the year-end wage file. Payroll is always at calendar year-end. 
 
Affordable Care Act 
Where can I get more information on the Affordable Care Act (ACA) functionality in Microsoft Dynamics GP? 

• Refer to Microsoft’s latest blog article about ACA: 
Microsoft Dynamics GP Year-End Update 2022: Affordable Care Act (ACA) 

 

• In the Detailed Module Information section of the Microsoft Dynamics GP Resource page, select Affordable 

Care Act/Year End to see the information about complying with ACA and other information about other year-

end changes. 

 

• There were several blog articles written to cover the ACA changes and functionality. All the blog links are listed 

in ACA blog links for Microsoft Dynamics GP. 

 
 
 
 
 
 
 
 
 
 
  

 
 
 
 
 

https://community.dynamics.com/blogs/post/?postid=fc90c41e-2721-4bd4-ab84-4e013c1858ee
https://learn.microsoft.com/en-us/dynamics-gp/resources
https://mbs2.microsoft.com/fileexchange/?fileID=b6386ed9-7351-46b2-8682-6e74ca756d1c
https://mbs2.microsoft.com/fileexchange/?fileID=b6386ed9-7351-46b2-8682-6e74ca756d1c
https://learn.microsoft.com/en-US/troubleshoot/dynamics/gp/aca-blog-links-dynamics-gp


                                 

 

 

PAYROLL YEAR-END RESOURCES 
 
Partner — Contact HOOPS for more information or if you need assistance with any of the items mentioned 
above.  Call (715) 831-9737 or email support@hoopsinc.com. 
 
Payroll Tax Facts — Check out Tax Updates at the Downloads & Updates section HERE to find out what year-
end maintenance and tax changes are included in each update and to download the update. All instructions 
for downloading and installing the tax updates will be provided there, as well. 
 
IRS Forms and Publications — Available at http://www.irs.gov/formspubs/index.html  
 
Electronic File Verification — Accuwage for Electronic File Verification available at 
http://www.ssa.gov/employer/accuwage/index.html  
 
Year-end Order Forms — Please call Deluxe Checks at 800-432-1281 and mention MM4321. 
 

mailto:support@hoopsinc.com
https://learn.microsoft.com/en-us/dynamics/s-e/gp/tugp2018_391
http://www.irs.gov/formspubs/index.html
http://www.ssa.gov/employer/accuwage/index.html

